[Bug] Pencil quits when clicking in grey area below strips

Hi, I believe I’ve found another bug. When I click in the empty grey area below the camera strip in the timeline, Pencil immediately quits.

It’s easy to replicate (as long as it’s not just my machine…!). Just open the Jan 14th Nightly Build and click on the grey section between the camera strip and the bottom scroll bar.

Again, I’m on Mac OSX El Capitan.

Hope this helps.

Funny thing, I didn’t see the grey area first. Then I realised I had to move the timeline a bit. And yes, it does happen to me as well(windows 10). But I noticed that there is a small thin safe line in the grey area just below the camera layer, where clicking wont crash the program. Below that safe line it will crash. bug

^ can confirm this in my version too

@neeby @sumit_makwana Thank you for reporting this guys, I too had noticed it but apparently Jonas might have fixed this while addressing a different problem. I’m not sure but I’ll tag him to this thread as well, so we’ll wait for his response.

@jonasthomas Is this critical bug related to the one that happened where the downwards layer behaviour was not working but when you moved a layer towards the grey area it crashed as well?

What do you think?

Hmm… This was something I was not aware of what I was doing was a drag and drop. The weird thing is that when I tried this, I’m unable to replicate… Weird… I’m running Ubuntu 14.04… Did someone fix this already? Or is something happening in something other linux?

I wonder if this one of these muli-part bugs. @Jose Moreno have you been able to replicated this?

@jonasthomas Although this bug is present in the JAN 14th 2016 version for Windows 7 as well, I managed to build & run February 11th 2016 build with Qt. The bug is not present anymore, however this seems to be because now anything below the bottom-most layer somehow becomes a selectable part of that same layer. So for example if I double click on the grey area I access the camera layer properties when it’s there.

I did notice a remainder of the layer bug that we saw before. When I try to bring any layer below the bottom-most layer, the only way to make it actually get below is to grab the layer and drop it beyond that “red” line shown in Sumit’s image.

If I drop the layer I’m dragging immediatly below the bottom layer, it will glitch visually and return to it’s “place”. You can also notice that black double line that appears to “previsualize” the layer “new” placement has a different motion in separate parts of the layers, one being where the layer display it’s name and the other where the actual frames are displayed.

This is what I meant on the last paragraph:


I’ve just been trying to do some colouring and while reordering the layers I came across this as well. I tried making a new camera layer but then they both jumped to the top and I couldn’t delete either of them. This seems to happen when I try to move a layer directly underneath the camera layer.

@neeby Yeah in the latest development versions you have to move the layer past beyond an imaginary slot line to get the layers below the bottom-most layer. I think I’m going to report this, since I believe it’s part of an earlier bug which as Jonas said it must be returning form the grave to haunt us. Hah.