[SOLVED] Video Is Audio Is delayed


#1

I just recently downloaded pencil 2d and everything was going well, but now I’m having a problem. Whenever I add audio into the animation it bugs out. The video plays for 13-14 frames in silence before freezing for a couple of seconds and continuing but with audio. The worst part is the audio starts from the beginning. I don’t understand why this started happening, when I first downloaded pencil 2d it worked fine.


#2

@Redikai Hi, if you downloaded the “stable” version of Pencil2D and there are issues with the sound can you try a development build? These have more fixes, and although they are considered unstable, sometimes they work fine for most cases.

Please download the version from February 13th. It’s the one I’m using and so far I haven’t had any issues with it. Plus I know there are things being fixes right now so any other version might have more difficult issues that will interrupt your work.

If this behavior continues to happen with this suggested version, please save the file and upload it so developers can take a look at it, as It might help to uncover what is the exact problem you’re facing.

It also would help to know what your operating system is (i.e windows 7, mac osx lion, linux ubuntu 16.04, etc), and what your computer specs are (i.e RAM size, CPU speed, especialized audio hardware that might be causing the problem, etc)


#3

It worked! Thanks for the help!


#4

@Redikai Good, glad that it’s working now. I’ll close this thread and mark it as solved then. If you need anything else related to this issue please keep commenting on this thread. If you have a new or different issue please open a new thread :slight_smile:


#5

It seems that this problem has returned. I’ve tried the most recent stable version but it didn’t help. I tried using an older version of pencil2d but that didn’t help either. I don’t know what is causing this.


#6

@Redikai Hey. some else reported a similar concern, however most of us aren’t having this issue. For now all I can say is that it appears to be hardware related, but I’m speculating based on the previous reports. We’ll have to review this issue again, so for now please try to work a rough audio placement using Pencil2D and then use a video editor to finalize how the audio interacts with your animation.