[SOLVED] Program Not Displaying Correctly on my HDTV

workaround_available
windows

#1

Hello,
I’m new to Pencil2D. I installed the program with no problem but when I open it on my High Definintion TV (that I use as my monitor with my PC) the text that describes the tools is over lapping. I had this problem with other programs that turned out to be an issue with my HDTV. My screen Res recommended is 3840 x 2160. I also am using a PC OS Windows 10 and have the screen zoom at 350%. Is anyone else having this problem? Is there a fix for this?

Thanks,
Jeetman


#2

@chchwy What do you think of this issue? I think it’s also related to other issue with high-dpi displays or high resolution dekstops.


#3

@jeetman Hi Jeetman, First of all would you mind sending us a screenshot of this issue? Thanks.

Currently developers know about the importance of High Definition displays, however we’re trying to work towards getting a better way to improve scaling on the interface and it’s icons for High-DPi and High resolution displays. It’s not an easy job, but it is a much needed improvement.

However right now I’m afraid there’s no “ultimate” solution we can pass on, other than to mess around with your DPI settings to subdue the text size, however the icons will still be very small.

For more info on how to adjust your windows DPI settings please see this article:


#4

Hello Jose,
Thank you for responding. the icons are small but I can still use them. That’s not the problem I’m having with Pencil2D. The problem is with the text display for the layer options and the frame numbers. The layer options are displayed as overlapping and the frame numbers are being obscured by the border frame directly above.

How do I attach screenshot?


#5

Hi @Jeetman
Maybe you can upload the screenshot to https://imgur.com/
and post a link here.


#6

Thank you Matt. I did as you requested. I uploaded a pic of my screen shot to Imgur.com. I also tried different DPI zoom percentages as suggested by Jose. It would change the size of the icons but the text never displayed properly. The pic is here. screen shot of Pencil2D on my HDTV


#7

Thanks for taking the time to continue with the follow-up @jeetman. It’s weird that images are not showing on the comments. I’ll re-post your image so MAtt can see it.

@chchwy I’ve seen this issue before with other users, and they also had windows10. Could it be a version specific problem? or perhaps a bug with QT itself? Although it seems very odd that there are few reports about this. Maybe the resolution has to be really high (above 2K) in order to trigger this issue.


#8

Jose and @chchwy,

I had some time today to play with the setting and I found the fix!!!

It’s an easy fix. I’m going to post a small tutorial to explain the steps. I think this will fix this issue for all HDTV’s but in case it is just a fix for my model, I’ll post what I’m using.

I also applied this fix to my paint program I use (Paintshop Pro X6) that would make the icons almost impossible to see and it worked for that program as well, so if anyone else has been dealing with this display problem in other programs, this may apply to those as well.


#9

For anyone looking for the fix jeetman mentions please look at the guide on our FAQ which was contributed by him: https://www.pencil2d.org/doc/faq.html#i-have-a-hi-dpi-screen--high-resolution-desktop-but-the-text-in-pencil2d-is-all-wonky--icons-are-too-small