Pencil 2D FAQ (now open)


(Jose Moreno) #41

@thenarrator Sure. You have to go to Preferences > Tools > Number of previous onion frames shown

But don’t get too crazy with it, try to use 10 frames tops. Here’s a visual aid to see what happens. Hope it helps.

http://imgur.com/XVePizB

p.s Don’t forget to turn on the onion skin for previous and next frames on the “Display Panel”. The little diamond on the center changes the onion skin from absolute to relative. That means you can see adjacent frames (absolute) or keyframe containers (relative) [this is helpful if your keyframes are already spaced over the timeline while establishing your timing].


(Stephanie) #42

hi i’m tying to download 0.5.4 for the windows 8 but it keep giving me this Error (Don’t know how to do screenshots) “the program can’t start because phonon4.dll is missing from your computer. Try reinstalling the program to fix this problem” but I’ve reinstalled it five if not more times and every time phonon4.dll was there what should I do

thanks in advance


(Jose Moreno) #43

@amateuranimator Hi. Sorry to hear you’ve been having difficulties. Please don’t use version 0.5.4 It’s an old version that has many problems.

We now have a development version that has been fixed a lot, and although it is not perfect it’s the best version yet! Also it works like a portable version so you don’t have to install it. Just download the ZIP file for November 2016 found here:

https://drive.google.com/drive/folders/0BxdcdOiOmg-CcWhLazdKR1oydHM#list

When you download this ZIP file, if you’re on Windows, make sure you take a look at the file properties before extracting it’s contents to unblock the file. After extracting then just run Pencil.exe and that’s it! Hope this helps.


(Stephanie) #44

It didn’t work but I’m not sure if I needed to find a specific file or if I just needed to look at the properties I also used the 64-bit do you think the 32-bit would work


(Jose Moreno) #45

@amateuranimator Hey. Hmm just to avoid further confusion here’s a video tutorial I made outlining the steps you have to take to ensure Pencil2D works.

If after following these steps it still does not work, then we’ll have to ask our lead developer to take a look into this issue. Hope this helps.


(Stephanie) #46

Thanks it did help :slight_smile:


(Zach Cantwell) #47

So I downloaded the nightly build of Pencil and it’s been working fantastic so far, only a few minor bugs. I’ll be getting a drawing tablet soon and I was wondering if the nightly build is compatible with tablets and if so, how will I set it up and get it working?
Thanks,
Zach


(Jose Moreno) #48

Hi thank you for your interest in pencil2D. I’ll give you a short answer followed by a longer explanation.

Short Answer: You can copy and paste anything that has been selected with the marquee tool, but “shifting” is not possible, I mean, you can paste the drawing on the same place but you’d have to redraw how the legs and the arms fit on the new pose.

Copying and pasting is a bit counter intuitive for now. But the main problem I see with bringing scanned images into Pencil2D, is that scanning would create images with colored background, so cropping those would be difficult on Pencil2D with the marquee tool.

I’d suggest you use Krita which is free and open source and would allow you to use a filter to turn white (or any color) into an alpha channel. After processing them you could then use their transform features to do what you want with ease and then re-export those to use in Pencil2D if you’d like.

EDIT: I’m sorry I got a notification that you had asked this question again today, but it was a mistake. Hope things are well, take care.


(Jose Moreno) #49

@zachcantwelltv Hey. For maximum compatibility please download the latest Nightly Build, don’t use the download version 0.5.4b. If you don’t know where to get it just visit the download section of our static page at Http://pencil2d.github.io

If you use a Wacom tablet it will work right out the box. The Pencil tool is a bit faulty right now as it needs about 50% of strenght to start working, but the Pen tool works like a charm.

If you’re planning on purchasing a screen tablet like a cintiq or a similar product, i’m afraid that I can’t say if it works or not properly. Some people have said it does some others have had issues, but this relates to your screen calibration and this mainly relates to how you install and configure your drivers, but we have no way to help with individual consumer hardware installation that since there are too many variables to consider and that’s what manuals are for.

Bottom line, if you install your tablet drivers and do all the required procedures, not only Pencil2D will work, but any other drawing program will work. It usually boils down to your computer configuration and your OS choice.

For example I use Windows 7 with an Intuos 5 Pro and it works great so far. Hope this helps to clear your doubts.

p.s. If all fails you can use Krita too.


(Marie) #50

Hi there,

I know the FAQ section covers what to do when your sound layer doesn’t work. However I followed the instructions for average users (God knows I’m not a computer veteran) and the sound layer still isn’t working.

I did the process three times just to make sure it wasn’t me, but it’s still not working.
I downloaded the file suggested and created the Qt folder in my C:/ drive and then extracted the folder inside the Qt older.
I then restarted pencil, inserted a sound layer, added my .WAV file and placed a second Key frame.
I used a 1 second .WAV file and had it set on 12Fps so my second frame was on 12.
sound is activated.

But it still isn’t working.

Any ideas where to go from here?

Kind regards


(Jose Moreno) #51

@marie Hi Marie, yes, there’s a development build of Pencil2D that has sound layers fixed. Please download it here:

https://drive.google.com/drive/folders/0BxdcdOiOmg-CcWhLazdKR1oydHM#list

Latest version for windows is Pencil2D-win32-20161102.zip
Latest version for MAC is Pencil2D-mac-20151219.zip

This is basically a portable version of Pencil2D so you don’t need to re-install it.

A small warning though, since this is a work in progress, you can load sounds ok on a layer, but you can only play it from the keyframe it was loaded to. That means no pause and resume.

There is no scrubbing function either, for now; I’m sure it will come later on though. Also when you save your project the sound won’t be saved so you’ll have to reload it everytime you open the file.


(Sophie) #52

I’m new to pencil, but I can never get my timeline to go past 240 frames. I’ve put a keyframe past 240, and it works, but I can see it on the timeline.


(Jose Moreno) #53

@tangenttangerines Hi! To change the size of the timeline please go to Edit > Preferences > Timeline. There you can change the length of the timeline.

Also, just in case please use Pencil2D Latest Nightl Build. Do not use version 0.5.4 or else you’ll suffer from lots of bugs that have already been fixed. If you need assistance on how to get the Nightly Build please take a look at this tutorial, it even has subtitles now:


(Tweedpawn) #54

Hello, I just want to say that out of all the current software I’ve tried out in the past three months, yours was the only one that had exactly what I needed to do what I want to do for animation. I really enjoy the simplicity of a program that places tradition frame by frame first instead of puppet-based animation.

However, I have downloaded the latest nightly build, and the plug-in to allow me to import videos, yet I do not see any options to import video. s this a currently disabled feature? I’ve looked around on the boards, but maybe I missed it?


(Jose Moreno) #55

@tweedpawn Hey! Glad to hear Pencil2D is being useful for you. So far there’s not a video import function available, only to export. I’ll make a feature request for this soon hoping it will be possible to implement.

If you want to import a video you’ll have to export an image sequence from a different program and then import that on Pencil2D, however we’re in the process of fixing a problem with the image sequence import where each image is imported every two frames. We are bound to release a New development build with these changes soon I hope.

What I can recommend to solve your issue for now is, if you can create a GIF from your video you can absolutely import that just fine into Pencil2D and rotoscope it, if that’s what you need.

I found a software that makes GIF’s directly from videos, it’s open source. Here’s the link:

And here’s a demo video from the creator:

Hope this helps :slight_smile:


(LonelyCottonball) #56

Hello,
I’m not really new to Pencil as I’ve already used it and gotten to know its features. However, when I export animations, I can’t help but notice that it cuts off the sides of some of my animations, and I’m unable to make it so that this doesn’t happen. Does the camera layer have any effect on this?


(Eddie) #57

I’m now to animation an I don’t know which version to download


(Jose Moreno) #58

@lonelycottonball Sure it does. Double click on the camera layer to change the export resolution. On the latest Nightly builds you will always see the camera layer “frame” to know what size your canvas is visually

@ryura100 you can download the latest development version on the following link under the “Nightly Build” section: http://pencil2d.github.io/download


(Jonathan) #59

Hello, I’m new to pencil2d so I’m not sure if this is the right place to ask

I’m having trouble to install it. I installed the pencil2d-0.5.4-20130728.1.x86_64.rpm from the repository with no issues however when I try to run it I get the following message:
“pencil: error while loading shared libraries: libgif.so.4: cannot open shared object file: No such file or directory”

I do have giflib-5.1.1 installed, with “libgif.so.7” on it, so it should run, shouldn’t it?


(Jose Moreno) #60

@dimstar Hey. I’m not too linux savvy but it seems those rpm were made with very specific libraries to run. For now I can only direct you to attempt two options:

First, there are some Nightly builds that were made available by a friend of the project you can look at them here:

https://drive.google.com/drive/folders/0B-3xNJ86y4WsSmVUWk5rb2VkcXM

I think you have to execute the “makefile” file on the terminal, but i’m not sure.

The second option is to compile the newest source yourself. There is a very recent guide to that end for ubuntu, but it should work on any debian based distribution.

If you successfully build it you’d be using the latest code with a lot of fixes, because the rpm you have is absolutely old. Let me know how it goes so I can see if there’s a way to ask a dev to assist us.