MyPaint version pre-alpha preview

(feeef) #1

I come with a very good news for all of you, fans of animations and fans of Pencil2D!

I have managed to put together a preview version of Pencil2D with MyPaint as the Bitmap brush engine. You can try it by cloning my repository and build the “mypaint” branch here

Of course, it is just a preview version and a many features are still broken, like the vector engine, zooming, moving, rotating the canvas and more… With this version, I just made sure that it is possible to draw on a bitmap layer and to animate with the timeline. I also made Pencil2D notice tablet pen proximity so if you use the eraser with your pen, you don’t have to touch the screen for the tool to switch to eraser.

Anyway, feel free to try out this version and let me know what you think! :slight_smile:

Pencil2D Mypaint

(feeef) #2

in order to keep Pencil’s user experience and the set of tools as it was before, I made the brush library represent the different brushes available for the current selected tool.

So if you click on the eraser, you will see all the eraser brushes in the library, if you click on the pencil tool, you will load pencils and sketching brushes.

The tools that currently work with mypaint are :

  • Pencil
  • Pen
  • Eraser
  • Brush
  • Smudge

(Jose Moreno) #3

@feeef Man, congrats! I’ll share this on the communities. Let’s see if someone wants to clone it and help you out for sure!

(gordie) #4

@feeef : you are incredible man !
This seems to be REALLY good work.
I’ll test that very soon.

Thanks !

(Jose Moreno) #5

@gordie You too man, good job on recovering the website, so far haven’t seen spammers like we used to! I tried to share this notice on every media site we have. Let’s hope someone else wants to help out to integrate the library.

(gordie) #6

PS : we want a bigger picture :wink:

(feeef) #7

@gordie, the picture can be seen here, at my media goblin page. If you click on the picture, you will see it full size.

(kaiko) #8

Hi @feeef
You are a man of word!
That is a really HUGE achievement for Pencil2D (meaning ALL involved with this idea)

I have downloaded it and managed to have it working, and that was a really good feeling.

So far the brushes from MYpaint are behaving marvellous. I love the smudge tools for mixing colours :wink:

About some features:
ROTATE canvas using keyboard R/Z.
MOVE the canvas using SPACE keyboard.
Change the default camera size to a similar value of your screen monitor (while Zoom is not working it will allow you to have the canvas fitting the whole area of your monitor if you wish)
Select CAMERA before Exporting any Image Sequence


(feeef) #9

I am glad you like this version @kaiko! :slight_smile:

Pan, zoom and rotate are the things that made me struggle the most so far. Once these features will be fixed (when I will get the time or help), things will be pretty straight forward to complete. Even the Vector engine should be easy to fix.

Libmypaint made me remove so much code from the core engine (I still have to cleanup though), this mypaint version could be ready before we manage to fix the current brush engine.

By the way, I didn’t implement the tools settings yet so they must be broken at the moment.

Also, I have only added the “deevad” library in the brush lib so far to keep it simple for the preview. We may have them all brushes in the future.

(kaiko) #10

@feeef :slight_smile:

Well, here I am with some issues (not sure if we have to open a new thread for just Issues from Pencil2D_MyPaint)

As there is no Zoom feature here, I started by increasing the size of the canvas and used Space keyboard for moving it around as I was painting (not animating yet :slight_smile: )
So, say I have the whole canvas painted and decide to re-paint an area of the canvas but for that I need to move the canvas (Space keyboard). After that everything from the canvas that was hidden from the main viewport will be deleted. So be aware :slight_smile:

I tried to paint an image from a photo and after a while of being painting, Pencil2D started to paint at will deleting some parts of the colouring that I have made or it acts replacing them with square colours presented on the last strokes…

That said, I started painting this window (see image here) and re-painted it about 10 times if not more, but with no luck at the end since Pencil2D insisted in changing things.
I decide to quit for now, in order to keep my sanity :smiley: till this issue is fixed.

(Vincent) #11


Thank you so much it looks amazing!
I’d love to try this, but I’ll have trouble to understand git and stuff and how to b…build :smiley:

I’ll find some tutos, thank you again!

(feeef) #12


Again, this is a pre-aplha preview only of the work in progress. It is not intended for actual work and may be very unstable as it is incomplete. So, please, don’t report issues about it yet.

As I said in previous posts, zooming rotating and moving the picture are not working. I should have been more specific and say that in the case of moving, it is not working because it “eats” your picture right now. I will disable the feature while it is broken.

As for the other bug, it may be linked to similar issues with the canvas. There is still some work to do with the canvas. Having an infinite canvas makes it a bit tricky to implement so I still need to find the right logic behind it.

(Matt) #13

That’s awesome @feeef

(GregorysonofCarl) #14

I just noticed this today and I think that a brush library is a fantastic addition to Pencil2D! Thank you for all your hard work!

I managed to build it too (yay!), and I must agree that the brushes feel great. Very quick and responsive. I’m looking forward to seeing them working with all of the brush properties so I can really take full advantage of them.

One detail with the new brush library is that they introduce directional brushes like the chisel. I was wondering if you had any plans for including direction adjustments for those brushes? I know that the current master doesn’t have that feature.

I would really like to help work on this project. I can’t promise much though since I’m barely beginning to understand signals and slots.

(feeef) #15

@gregorysonofcarl, thanks for the suggestion and the help!

In a first step, I plan to only have the brushes that correspond to the current Pencil2D tools (Pencils/Sketching, Pens/Line-art, Brushes/Painting, Erasers and Smudge). This way, the user experience is not much different from the current application while having a much better brush engine as currently. If the brushes you are talking about fit in the Sketching, Line-Art or painting category, we may add them straight away.

We may include more tools in the future but it won’t happen before having a first stable version of Pencil2D and before being discussed of course!

(kaiko) #16

A simple test using Pencil2D with MyPaint brushes

Pencil2D with MyPaint brushes

(feeef) #17

It looks very good @kaiko! I am happy to see some beautiful stuff already being done with this version! :slight_smile: It is promising!

Thank you!

(kaiko) #18

Your words got me by surprised… I wasn’t expecting that to be honest :slight_smile: … and gave me some inspiration.

Clock (cukoo)

Here an image that I am intending to use for a simple short animation. It will take some time though to finish it and hopefully meanwhile some new development in Pencil2D will allow other approaches.

(feeef) #19

Wow! That is even better! Well done @kaiko!

(GregorysonofCarl) #20

Here’s an example of what I’m referring to regarding directional tools. In this image, I’m using the “basic_knife_smudging_tool” found in the brush tool library. I manipulated the screen shot in GIMP to create the demo image.

Notice the beautifully drawn dial in the tool option widget that controls brush angle.
I agree that it is important to avoid big changes to the user experience with single updates. Adding a feature like this should probably wait for a future project, but it will be on my wish list once MyPaint gets released into the wild.

Side note: Trying to build MyPaint on Linux Mint 17.2 fails because the new QSignalBlocker is only available starting with qt v5.3 and Synaptic Package Manager has only v5.2 available. It builds fine on Debian jessie though. Their Synaptic Package Manager has v5.3. Weird. It’s probably not a big deal, and I’m sure there are ways around it. I did find it odd, however, that two Synaptic Package Managers had different libraries available.