[Improvement] No limit to loop range tool end


#1

So on the latest nightly build I was looking to loop a part of my animation, but after a lot of clicking of the ‘up’ arrow, I found the range limit won’t go past 100 frames. My animation’s quite a bit longer than that, so it presented a problem.

Would it be possible for there to be no limit to the range end? Additionally, has anyone mentioned how it’s not possible to type in values manually? Ie. you have to click the little arrow keys to change things like the FPS and the loop range, instead of typing in the numbers manually, which would be quicker.

Thanks


#2

@neeby Hmm, well it’s difficult to roll-flip 100 drawings on paper too. I don’t think it’s really meant to go beyond, usually one utilizes small ranges to “flip-trough” a specific part.

If you require to play a range beyond that I think you would be better by watching the whole animation, unless you have about 1000 drawn frames, but by then Pencil2D would crash due to the immense amount of memory needed to handle all those drawings (unless you have like 64 gigs of ram memory :stuck_out_tongue: ).

What I mean to say is this: Right now it is recommended to work each Pencil2D file as a separate Cut or “Animation Scene” Which usually won’t last more than 2 minutes or 300 frames.

This is professional advice, not just a warning because of the software limitation. Even if you tried to do that in commercial software like Photoshop or TVPaint, creating an exceedingly long animation in either will result in guaranteed headaches.

However I’ll tag a developer to see if we can have a higher range for it since we will also have to deal with the memory management thing in the future.


#3

@feeef What do you think of this problem? Is it possible to adjust the maximum frame count for the range feature without altering everything? I assume there should be a constant or even a variable that allows for that, so it shouldn’t be as difficult, but you never know haha.


#4

@morr This was what I meant, really - my animation is about 9 seconds long (219 frames at 24fps) and I was hoping to look at small segments after that 100-frame cutoff. Does Pencil have a frame limit? If not, maybe one should be decided if we’re keeping professional workflows in mind?

I do appreciate your advice re. a professional workflow btw, so I will keep it in mind!

 


#5

@neeby Ohhhh! I’m sorry! I think I originally misunderstood what you meant, because I assume you thought the “loop range” feature would give you more room to work. I’ve just reviewed the Nightly Build and I now see what I think you meant.

The Loop range tool is just for “looping” but in order to extend the actual amount of frames in the timeline past beyond the 100th frame, you have to go to:

Edit Menu > Preferences > Timeline > Timeline Size in frames: By default it will appear as 20 (which is a bug)

Let me explain in detail how this would work. Default 20 frames in that box is congruent to having 99 frames. If you type 21, youll get 100 frames, if you type 22 youll get 101 frames…so think of 20 as frame “zero” and any amount of frames you add to it, will be “added” in the timeline past the 99th frame. If you type 30, you will add 10 frames to 99, so you’ll get 109 frames. You follow?

It seems it also depends on the position of the timeline, so for example if you rearrange the timeline panel to the left, there will be less space to show the frames, so it will be cutoff at frame 45. Which is also a bug.

This is a bug I had seen in the early days as well, because I was new to the program I didn’t know what was happening but I didn’t think it ran so deep. I’ll report it right away.

The “Loop range” however is limited to 100 frames, so…yeah that’s what I mean with my previous comment LoL. Sorry about that. Hope this will actually help to extend the timeline now so you can review more stuff :slight_smile:

p.s you can have up to 9999 frames typed on the Timeline size box, so you can have up to 10024 frames for your animation :stuck_out_tongue:


#6

Things are a little different for me on my Mac - the default timeline size in frames for me is 240. I tried increasing it, and then increasing the upper frame limit (as well as the lower frame limit, bearing in mind what you said about the 100-frame range limit) but the playback still wouldn’t go past frame 99.

Some odd behaviour, as you said - I tried typing in 25 for ‘Timeline size in frames’ and it’s given me 123 frames…

It’s not a huge deal for me right now if it doesn’t work, it was just something I noticed while experimenting :slight_smile: thanks for your help